erlug
[Top] [All Lists]

Re: [Erlug] Aggiornamento Debian 7.0

To: ERlug - Lista Pubblica <erlug@xxxxxxxxxxxxxx>
Subject: Re: [Erlug] Aggiornamento Debian 7.0
From: vic <vic@xxxxxxxxxxxxxx>
Date: Mon, 27 May 2013 18:34:11 +0200
Il 27/05/2013 15:00, Maurizio Lemmo - Tannoiser ha scritto:
* Monday 27 May 2013, alle 13:58, vic66 scrive:

Primo fra tutti il warning di locales che non riesce a settare il
default che ho sempre avuto in it_IT@euro.

locale: Cannot set LC_CTYPE to default locale: No such file or directory

locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory


Nel .bashrc di tutti gli utenti ho l'export del locale:

export LANG=it_IT@euro
export LC_ALL=it_IT@euro
export LC_CTYPE=it_IT@euro
export LC_CTYPE="UTF-8"

Queste ultime due si sovrappongono, e it_IT@euro SE usi utf-8 non hanno
senso (era l'esteso con l'euro NON utf-8)

Trasforma in it_IT.UTF-8

(se non ce l'ha generalo con dpkg-reconfigure -plow locales)


Messaggi tipo questi:

insserv: warning: script 'K01amavis' missing LSB tags and overrides
insserv: warning: script 'K01dbus-1' missing LSB tags and overrides
insserv: warning: script 'K01ddclient' missing LSB tags and overrides
insserv: warning: script 'K01usbmgr' missing LSB tags and overrides
insserv: warning: script 'K01openvpn' missing LSB tags and overrides
insserv: warning: script 'K01setwireless' missing LSB tags and overrides

insserv: warning: script 'S19xfree86-common' missing LSB tags and overrides
insserv: warning: script 'S19nviboot' missing LSB tags and overrides
insserv: warning: script 'S19libdevmapper1.01' missing LSB tags and
overrides
insserv: warning: script 'S19initrd-tools.sh' missing LSB tags and overrides


Non ho capito se siano warning gravi o meno, ma anche qua mi piacerebbe

risolvere per avere un sistema un po' pulito.

Non sono gravi in senso stretto ma sono necessari se vuoi che non dia i
warings. In pratica: gli script di avvio in init.d una volta li scrivevi
come ti pareva (tu o il maintainer), ora hanno un "protocollo".

A me pare strano che nella nuova ci siano script (quelli sono link agli
script originali) non aggiornati al nuovo sistema. Sicuro che non gli
hai impedito di aggiornarli?

confermo che non ho impedito alcunche', pero' ho visto che sono pacchetti che parrebbero essere obsoleti, almeno a una prima occhiata. Ad esempio provando un apt-get install --reinstall amavis mi dice che mi installa amavis-new al suo posto, openvpn era stata disinstallato cosi' come altri, initrd-tools non c'e' piu', etc.

I casi sono 2: o rimuovi insserv, o aggiorni gli script.

Caso uno non possibile, se cerco di rimuoverlo mi dice che apache2 ha dipendenze insoddisfatte... non so cosa c'entri ma fino al tentativo di rimozione apache2 funzia, e visto che non rimuove insserv continua a funzionare.

Sto cercando di reinstallare i pacchetti che dovrebbero essere ancora esistenti e ho visto che con la nuova installazione alcuni vanno a posto.

--
Vic

<Prev in Thread] Current Thread [Next in Thread>